The US Cybersecurity and Infrastructure Security Agency encourages organizations to patch a critical flaw in the BIG-IP family of application delivery controllers, as firms find evidence that attackers are scanning for the critical vulnerability.

Attackers targeted a critical vulnerability in the BIG-IP family of application delivery controllers — devices that secure major web applications and help balance traffic loads for large sites — only two days after network-appliance maker F5 patched the issue, according to two organizations.

The attacks target F5 devices that have exposed the administrative user interface to the Internet, a SANS incident handler stated in an entry on the SANS Internet Storm Center blog. A number of opportunistic scans are targeting the BIG-IP Traffic Management User Interface (TMUI), aiming to trigger the vulnerability and take control of insecure devices.

For the thousands of BIG-IP appliances that expose the interface to the Internet, the scanning could result in extensive compromises of the protected sites and networks, says Johannes Ullrich, dean of research at the SANS Technology Institute and a founder of the Internet Storm Center.

“The problem is that these devices are perimeter devices, so a single device compromise means that the entire network behind it is compromised as well,” he says.

The attacks started only two days after F5, the maker of the BIG-IP products, announced on July 1 that its products had two vulnerabilities, one of which is a remote code execution attack that allows code to be injected into the appliance’s configuration manager.

The vulnerability “results from security flaws in multiple components, such as one that allows directory traversal exploitation,” says Mikhail Klyuchnikov, a security expert at Positive Technologies, who found and initially reported the vulnerabilities. “This is particularly dangerous for companies whose F5 BIG-IP web interface is listed on search engines such as Shodan. Fortunately, most companies using the product do not enable access to the interface from the Internet.”

Positive Technologies released its own advisory on July 2, the day after the patch. Active exploit of the most critical vulnerability started on July 3, according to security consultancy NCC Group, which also detected scans. By July 5, fully functioning exploits and payloads were being shared on Twitter and Metasploit modules were available, according to NCC Group.

F5’s BIP-IP devices are used as application-delivery controller by many large companies, with F5 saying that 48 companies in the Fortune 50 use the devices. 

The vulnerability (CVE-2020-5902) occurs in the TMUI, also referred to as the Configuration utility, giving unauthenticated attackers with access to the interface the ability to execute arbitrary code, including the ability to create files, delete, and disable service.

The vulnerability could have affected at least 8,000 devices in June, according to Positive Technologies. Most of the vulnerable devices — 40% — were in the United States, while 16% were in China. Other countries with significant installations are Taiwan, Canada, and Indonesia.

Attacks have attempted to exploit vulnerable BIG-IP devices and download the password file. At least two staged payloads, which initially compromise the device and then attempt to download and install other malicious software to extend control, were observed as well.

The rapid reverse engineering of the patch is unsurprising because the exploit is very simple, according to the NCC Group. Using three characters, an attacker can try to run code in what should be an unreachable directory.

“[I]t can be described as a directory traversal vulnerability,” NCC Group stated in its analysis. “This ability combined with functionality native to the device provides the ability to access files, upload files and execute code without authentication.”

While at least 8,400 BIG-IP devices had the control interface accessible from the Internet in late June, as of July 6, fewer than 2,000 devices appeared to be vulnerable, according to SANS’s Ullrich. 

The network infrastructure vulnerability comes a week after another popular perimeter security device maker, Palo Alto Networks, warned that its devices had a vulnerability in the way that they processes Security Assertion Markup Language (SAML), allowing an attacker to bypass the security. 

Because the devices are easier to test these days, more vulnerabilities may be in the works, Ullrich says.

“There are all these perimeter devices, and researchers have really focused on them, because they are much easier to test these days,” he says. “Most vendors provide virtual devices that you can download and test and not have to shell out a lot of cash.”

Related Content

Veteran technology journalist of more than 20 years. Former research engineer. Written for more than two dozen publications, including CNET News.com, Dark Reading, MIT’s Technology Review, Popular Science, and Wired News. Five awards for journalism, including Best Deadline … View Full Bio

 

Recommended Reading:

More Insights



Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here